Triumph Torque Logo
 
Tuesday, 26 September 2017 Register | Login
Next PostTech Posts > Problem Solving > Weel they did warn me-2001 Speed triple dash electrics issues
Info
.
Message
Shazbot
North Buckinhamshire,
United Kingdom

Posts: 7
Speed Triple 955i (99-01)


02 Jul 2017 17:06
Hi just got a 2001 Speed triple 955i having had J products since 1981!
All is working apart form two dash issues which haven't specifically come up in a search on here.
1. temp gauge is fine until I turn the lights on when it sails off the scale, turn the lights off and it settles back to relevant temp.
Assume the lighting wiring is a source of the issue?

2. Indicator warning light on dash doesn't work properly. Had the clocks apart to see if there was a blown bulb and there wasn't one. Checking with a multi meter it seems to be receiving low voltage. put a low voltage mini instrument bulb in (not the the proper T5) it glows very dimly when flashing

Indicators themselves work properly albeit they are aftermarket mini jobs probably LED ?

Any starters for 10 ?

For the moment I can live with it but concerned if the ECU is getting hooky temp readings when the lights are on affecting fueling.

My mate did warn me that i would likely get a different ownership experience with owning a Triumph and he seems to be correct :grin:
Advertisement
Remove adverts by upgrading to a premier account
Next PostTech Posts > Problem Solving > Weel they did warn me-2001 Speed triple dash electrics issues
Start New ThreadForum Jump:
Who's Online?
Guests:73
Members:1
Premiers:0

top
Triumph Torque
- About Us
- Community Guidelines
- Contact Us
- Statistics
Site Information
- Site Help
- Site Status
- Site Updates
Member Information
- Login / Register
- Merchandise
- Obituaries